Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 29, 2025 - 23:30 BST
Scheduled
Unfortunately we need to perform some urgent scheduled maintenance this evening following the work completed over the weekend, during which time the portal will be unavailable. We expect this to take no longer than 30 minutes, but most-likely will be under 10 minutes. There will be no data loss during this time and it will not affect any telematics devices. We apologise for any inconvenice this causes.
Posted May 29, 2025 - 09:15 BST
This scheduled maintenance affected: Axscend Portal, Axscend API, and Axscend Mobile Apps.